Before installing easy-thumbnails, you’ll obviously need to have copy of Django installed. For the 2.5 release, both Django 1.4 and Django 1.7 or above is supported.

By default, all of the image manipulation is handled by the Python Imaging Library (a.k.a. PIL), so you’ll probably want that installed too.

Installing easy-thumbnails

The easiest way is to use an automatic package-installation tools like pip.

Simply type:

pip install easy-thumbnails

Manual installation

If you prefer not to use an automated package installer, you can download a copy of easy-thumbnails and install it manually. The latest release package can be downloaded from easy-thumbnail’s listing on the Python Package Index.

Once you’ve downloaded the package, unpack it and run the installation script:

python install

Configuring your project

In your Django project’s settings module, add easy-thumbnails to your INSTALLED_APPS setting:


Run python migrate easy_thumbnails.

You’re done! You’ll want to head on over now to the usage documentation.